Debian NEW package overview for ruby-warning
ruby-warning_1.2.1-1_amd64.changes (click to toggle)
Format:1.8
Date:Sat, 09 Oct 2021 01:30:05 +0530
Source:ruby-warning
Binary:ruby-warning
Architecture:source all
Version:1.2.1-1
Distribution:unstable
Urgency:medium
Maintainer:Debian Ruby Team <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Changed-By:Sruthi Chandran <srud@debian.org>
Description:
ruby-warning - Add custom processing for warnings
Closes:995955
Changes:
ruby-warning (1.2.1-1) unstable; urgency=medium

  * Initial release (Closes: #995955)
Files:
62e39df0df9820ac331913374e069dfd 1890 ruby optional ruby-warning_1.2.1-1.dsc
b0f1d4641b257ca5f0e346b289e6de0c 9070 ruby optional ruby-warning_1.2.1.orig.tar.gz
4d6060b5d83be6b41d95ec6c777eacee 2164 ruby optional ruby-warning_1.2.1-1.debian.tar.xz
61b9eaa2d6eb62e8c6494a1c5e7488e5 8408 ruby optional ruby-warning_1.2.1-1_all.deb
5082a3d62a66577d2a7e5d884f0bf2aa 8913 ruby optional ruby-warning_1.2.1-1_amd64.buildinfo
ruby-warning_1.2.1-1.dsc (click to toggle)
Format:3.0 (quilt)
Source:ruby-warning
Binary:ruby-warning
Architecture:all
Version:1.2.1-1
Maintainer:Debian Ruby Team <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Uploaders:Sruthi Chandran <srud@debian.org>
Homepage:https://github.com/jeremyevans/ruby-warning
Standards-Version:4.6.0
Vcs-Browser:https://salsa.debian.org/ruby-team/ruby-warning
Vcs-Git:https://salsa.debian.org/ruby-team/ruby-warning.git
Testsuite:autopkgtest-pkg-ruby
Build-Depends:debhelper-compat (=13), gem2deb (>=1), rake, ruby-minitest-global-expectations
Package-List:ruby-warning deb ruby optional arch=all
Files:
b0f1d4641b257ca5f0e346b289e6de0c 9070 ruby-warning_1.2.1.orig.tar.gz
4d6060b5d83be6b41d95ec6c777eacee 2164 ruby-warning_1.2.1-1.debian.tar.xz
Ruby-Versions:all
lintian 2.94.0~bpo10+1 check for ruby-warning_1.2.1-1.dsc (click to toggle)
README.source for ruby-warning_1.2.1-1.dsc (click to toggle)
No README.source in this package
control file for ruby-warning_1.2.1-1_all.deb (click to toggle)
Package:ruby-warning
Version:1.2.1-1
Architecture:all
Maintainer:Debian Ruby Team <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Installed-Size:31
Section:ruby
Priority:optional
Homepage:https://github.com/jeremyevans/ruby-warning
Description:
Add custom processing for warnings
 ruby-warning adds custom processing for warnings, including the
 ability to ignore specific warning messages, ignore warnings
 in specific files/directories, include backtraces with warnings,
 treat warnings as errors, deduplicate warnings, and add
 custom handling for all warnings in specific files/directories.
Ruby-Versions:all
lintian 2.94.0~bpo10+1 check for ruby-warning_1.2.1-1_all.deb (click to toggle)
contents of ruby-warning_1.2.1-1_all.deb (click to toggle)
drwxr-xr-x root/root         0 2021-10-08 20:00 ./
drwxr-xr-x root/root         0 2021-10-08 20:00 ./usr/
drwxr-xr-x root/root         0 2021-10-08 20:00 ./usr/share/
drwxr-xr-x root/root         0 2021-10-08 20:00 ./usr/share/doc/
drwxr-xr-x root/root         0 2021-10-08 20:00 ./usr/share/doc/ruby-warning/
-rw-r--r-- root/root      1777 2021-10-08 19:34 ./usr/share/doc/ruby-warning/README.rdoc.gz
-rw-r--r-- root/root       159 2021-10-08 20:00 ./usr/share/doc/ruby-warning/changelog.Debian.gz
-rw-r--r-- root/root       595 2021-10-08 19:34 ./usr/share/doc/ruby-warning/changelog.gz
-rw-r--r-- root/root      1427 2021-10-08 20:00 ./usr/share/doc/ruby-warning/copyright
drwxr-xr-x root/root         0 2021-10-08 20:00 ./usr/share/rubygems-integration/
drwxr-xr-x root/root         0 2021-10-08 20:00 ./usr/share/rubygems-integration/all/
drwxr-xr-x root/root         0 2021-10-08 20:00 ./usr/share/rubygems-integration/all/gems/
drwxr-xr-x root/root         0 2021-10-08 20:00 ./usr/share/rubygems-integration/all/gems/warning-1.2.1/
drwxr-xr-x root/root         0 2021-10-08 20:00 ./usr/share/rubygems-integration/all/gems/warning-1.2.1/lib/
-rw-r--r-- root/root     10102 2021-10-08 20:00 ./usr/share/rubygems-integration/all/gems/warning-1.2.1/lib/warning.rb
drwxr-xr-x root/root         0 2021-10-08 20:00 ./usr/share/rubygems-integration/all/plugins/
drwxr-xr-x root/root         0 2021-10-08 20:00 ./usr/share/rubygems-integration/all/specifications/
-rw-r--r-- root/root      1957 2021-10-08 20:00 ./usr/share/rubygems-integration/all/specifications/warning-1.2.1.gemspec

Timestamp: 08.10.2021 / 21:01:00 (UTC)