corner image corner image corner image corner image Debian NEW package overview for nss-pem
nss-pem_1.0.4-1_amd64.changes (click to toggle)
Format:1.8
Date:Thu, 06 Dec 2018 19:32:22 +0200
Source:nss-pem
Binary:nss-plugin-pem
Architecture:source amd64
Version:1.0.4-1
Distribution:unstable
Urgency:medium
Maintainer:Debian FreeIPA Team <pkg-freeipa-devel@lists.alioth.debian.org>
Changed-By:Timo Aaltonen <tjaalton@debian.org>
Description:
nss-plugin-pem - PEM file reader for Network Security Services (NSS)
Closes:888820
Changes:
nss-pem (1.0.4-1) unstable; urgency=medium

  * Initial release (Closes: #888820)
Files:
b3fee3d016942d16df237f523664208d 2067 libs optional nss-pem_1.0.4-1.dsc
b78bb88027af4131fe5f5dd4a710a0b2 20245824 libs optional nss-pem_1.0.4.orig.tar.xz
d6fa3f5dc792b64204730694193e67a2 3964 libs optional nss-pem_1.0.4-1.debian.tar.xz
f03e826f7cb1c6bb39a19acc58bb7618 6893 libs optional nss-pem_1.0.4-1_amd64.buildinfo
04e84fbbc8a17442aded865ca51b7ea2 54420 libs optional nss-plugin-pem_1.0.4-1_amd64.deb
nss-pem_1.0.4-1.dsc (click to toggle)
Format:3.0 (quilt)
Source:nss-pem
Binary:nss-plugin-pem
Architecture:any
Version:1.0.4-1
Maintainer:Debian FreeIPA Team <pkg-freeipa-devel@lists.alioth.debian.org>
Uploaders:Timo Aaltonen <tjaalton@debian.org>
Homepage:https://github.com/kdudka/nss-pem
Standards-Version:4.2.1
Vcs-Browser:https://salsa.debian.org/freeipa-team/nss-pem.git
Vcs-Git:https://salsa.debian.org/freeipa-team/nss-pem.git
Build-Depends:debhelper (>=10), cmake, libnss3-dev, pkg-config, quilt, libnspr4-dev (>=2:4.12), zlib1g-dev, libsqlite3-dev (>=3.3.9), libnss3-tools:native (>=2:3.19-1-1~)
Package-List:nss-plugin-pem deb libs optional arch=any
Files:
b78bb88027af4131fe5f5dd4a710a0b2 20245824 nss-pem_1.0.4.orig.tar.xz
d6fa3f5dc792b64204730694193e67a2 3964 nss-pem_1.0.4-1.debian.tar.xz
lintian 2.5.113~bpo9+1 check for nss-pem_1.0.4-1.dsc (click to toggle)
README.source for nss-pem_1.0.4-1.dsc (click to toggle)
nss-pem
=======

This source embeds src:nss because it needs some headers and static libs
that the nss maintainer has refused to package, see bugs:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=855879
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=732201

if the situation changes and the files are packaged by src:nss then the
embedded copy can be dropped.

The files that libnsspem.so needs for its build are:
 private headers: alghmac.h blapi.h
 static libs: libfreebl.a nssb.a nssckfw.a
control file for nss-plugin-pem_1.0.4-1_amd64.deb (click to toggle)
Package:nss-plugin-pem
Source:nss-pem
Version:1.0.4-1
Architecture:amd64
Maintainer:Debian FreeIPA Team <pkg-freeipa-devel@lists.alioth.debian.org>
Installed-Size:192
Depends:libc6 (>=2.14), libnspr4 (>=2:4.12), libnss3 (>=2:3.13.4-2~)
Replaces:libnsspem
Provides:libnsspem
Section:libs
Priority:optional
Multi-Arch:same
Homepage:https://github.com/kdudka/nss-pem
Description:
PEM file reader for Network Security Services (NSS)
 This package provides a PEM file reader for Network Security Services (NSS),
 implemented as a PKCS#11 module.
lintian 2.5.113~bpo9+1 check for nss-plugin-pem_1.0.4-1_amd64.deb (click to toggle)
contents of nss-plugin-pem_1.0.4-1_amd64.deb (click to toggle)
drwxr-xr-x root/root         0 2018-12-06 17:32 ./
drwxr-xr-x root/root         0 2018-12-06 17:32 ./usr/
drwxr-xr-x root/root         0 2018-12-06 17:32 ./usr/lib/
drwxr-xr-x root/root         0 2018-12-06 17:32 ./usr/lib/x86_64-linux-gnu/
drwxr-xr-x root/root         0 2018-12-06 17:32 ./usr/lib/x86_64-linux-gnu/nss/
-rw-r--r-- root/root    175352 2018-12-06 17:32 ./usr/lib/x86_64-linux-gnu/nss/libnsspem.so
drwxr-xr-x root/root         0 2018-12-06 17:32 ./usr/share/
drwxr-xr-x root/root         0 2018-12-06 17:32 ./usr/share/doc/
drwxr-xr-x root/root         0 2018-12-06 17:32 ./usr/share/doc/nss-plugin-pem/
-rw-r--r-- root/root       156 2018-12-06 17:32 ./usr/share/doc/nss-plugin-pem/changelog.Debian.gz
-rw-r--r-- root/root      6304 2018-10-03 06:47 ./usr/share/doc/nss-plugin-pem/copyright
drwxr-xr-x root/root         0 2018-12-06 17:32 ./usr/share/lintian/
drwxr-xr-x root/root         0 2018-12-06 17:32 ./usr/share/lintian/overrides/
-rw-r--r-- root/root       209 2018-12-06 17:11 ./usr/share/lintian/overrides/nss-plugin-pem

Timestamp: 06.12.2018 / 19:01:23 (UTC)