corner image corner image corner image corner image Debian NEW package overview for node-eslint-plugin-requirejs
node-eslint-plugin-requirejs_4.0.0-1_amd64.changes (click to toggle)
Format:1.8
Date:Sun, 27 Oct 2019 19:25:13 +0100
Source:node-eslint-plugin-requirejs
Binary:node-eslint-plugin-requirejs
Architecture:source all
Version:4.0.0-1
Distribution:experimental
Urgency:low
Maintainer:Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Changed-By:Jonas Smedegaard <dr@jones.dk>
Description:
node-eslint-plugin-requirejs - enforce code conventions for RequireJS modules with ESLint
Closes:943670
Changes:
node-eslint-plugin-requirejs (4.0.0-1) experimental; urgency=low

  * Initial release.
    Closes: Bug#943670.
Files:
2280b520a80f4e53e78800115751fbd8 2255 javascript optional node-eslint-plugin-requirejs_4.0.0-1.dsc
29f4416c6107e5edddd70ec2a34b71f2 57809 javascript optional node-eslint-plugin-requirejs_4.0.0.orig.tar.gz
ca1142ab18d86b249f805c7ab8d5e259 4460 javascript optional node-eslint-plugin-requirejs_4.0.0-1.debian.tar.xz
a7d92c2830818622b8d4205865701f93 20776 javascript optional node-eslint-plugin-requirejs_4.0.0-1_all.deb
9eab299af775263955c1e6cb911aa1ec 8688 javascript optional node-eslint-plugin-requirejs_4.0.0-1_amd64.buildinfo
node-eslint-plugin-requirejs_4.0.0-1.dsc (click to toggle)
Format:3.0 (quilt)
Source:node-eslint-plugin-requirejs
Binary:node-eslint-plugin-requirejs
Architecture:all
Version:4.0.0-1
Maintainer:Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Uploaders:Jonas Smedegaard <dr@jones.dk>,
Homepage:https://github.com/cvisco/eslint-plugin-requirejs
Standards-Version:4.4.1
Vcs-Browser:https://salsa.debian.org/js-team/node-eslint-plugin-requirejs
Vcs-Git:https://salsa.debian.org/js-team/node-eslint-plugin-requirejs.git
Testsuite:autopkgtest
Testsuite-Triggers:mocha, node-eslint
Build-Depends:debhelper, node-eslint<!nocheck>, mocha<!nocheck>, pandoc<!nodoc>
Package-List:node-eslint-plugin-requirejs deb javascript optional arch=all
Files:
29f4416c6107e5edddd70ec2a34b71f2 57809 node-eslint-plugin-requirejs_4.0.0.orig.tar.gz
ca1142ab18d86b249f805c7ab8d5e259 4460 node-eslint-plugin-requirejs_4.0.0-1.debian.tar.xz
lintian 2.29.0~bpo9+1 check for node-eslint-plugin-requirejs_4.0.0-1.dsc (click to toggle)
O: node-eslint-plugin-requirejs source: missing-license-text-in-dep5-copyright GPL-3+ (paragraph at line 44)
N: License is in License-Reference field (see bug#786450)
O: node-eslint-plugin-requirejs source: missing-license-paragraph-in-dep5-copyright gpl-3+ (paragraph at line 10)
README.source for node-eslint-plugin-requirejs_4.0.0-1.dsc (click to toggle)
No README.source in this package
control file for node-eslint-plugin-requirejs_4.0.0-1_all.deb (click to toggle)
Package:node-eslint-plugin-requirejs
Version:4.0.0-1
Architecture:all
Maintainer:Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Installed-Size:117
Depends:node-ignore, nodejs
Enhances:eslint
Section:javascript
Priority:optional
Homepage:https://github.com/cvisco/eslint-plugin-requirejs
Description:
enforce code conventions for RequireJS modules with ESLint
 eslint-plugin-requirejs provides a plugin for ESLint
 covering JavaScript code targeted RequireJS.
 .
 ESLint is a tool for identifying and reporting on patterns
 found in ECMAScript/JavaScript code.
 .
 RequireJS is a JavaScript file and module loader.
lintian 2.29.0~bpo9+1 check for node-eslint-plugin-requirejs_4.0.0-1_all.deb (click to toggle)
contents of node-eslint-plugin-requirejs_4.0.0-1_all.deb (click to toggle)
drwxr-xr-x root/root         0 2019-10-27 18:25 ./
drwxr-xr-x root/root         0 2019-10-27 18:25 ./usr/
drwxr-xr-x root/root         0 2019-10-27 18:25 ./usr/share/
drwxr-xr-x root/root         0 2019-10-27 18:25 ./usr/share/doc/
drwxr-xr-x root/root         0 2019-10-27 18:25 ./usr/share/doc/node-eslint-plugin-requirejs/
-rw-r--r-- root/root     16702 2019-10-27 18:25 ./usr/share/doc/node-eslint-plugin-requirejs/README.html
-rw-r--r-- root/root      1869 2019-10-27 18:25 ./usr/share/doc/node-eslint-plugin-requirejs/README.txt.gz
-rw-r--r-- root/root       158 2019-10-27 12:29 ./usr/share/doc/node-eslint-plugin-requirejs/TODO.Debian
-rw-r--r-- root/root       174 2019-10-27 18:25 ./usr/share/doc/node-eslint-plugin-requirejs/changelog.Debian.gz
-rw-r--r-- root/root      2683 2019-03-19 20:42 ./usr/share/doc/node-eslint-plugin-requirejs/changelog.gz
-rw-r--r-- root/root      1792 2019-10-27 11:40 ./usr/share/doc/node-eslint-plugin-requirejs/copyright
drwxr-xr-x root/root         0 2019-10-27 18:25 ./usr/share/nodejs/
drwxr-xr-x root/root         0 2019-10-27 18:25 ./usr/share/nodejs/eslint-plugin-requirejs/
-rw-r--r-- root/root      2090 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/index.js
drwxr-xr-x root/root         0 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/
drwxr-xr-x root/root         0 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/
-rw-r--r-- root/root      3394 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/amd-function-arity.js
-rw-r--r-- root/root      2099 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/enforce-define.js
-rw-r--r-- root/root      1163 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-amd-define.js
-rw-r--r-- root/root      1615 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-assign-exports.js
-rw-r--r-- root/root      1835 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-assign-require.js
-rw-r--r-- root/root      1724 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-commonjs-exports.js
-rw-r--r-- root/root      1790 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-commonjs-module-exports.js
-rw-r--r-- root/root      1690 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-commonjs-return.js
-rw-r--r-- root/root      1219 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-commonjs-wrapper.js
-rw-r--r-- root/root      1547 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-conditional-require.js
-rw-r--r-- root/root      1654 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-dynamic-require.js
-rw-r--r-- root/root      1180 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-function-define.js
-rw-r--r-- root/root      1205 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-invalid-define.js
-rw-r--r-- root/root      1234 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-invalid-require.js
-rw-r--r-- root/root      2122 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-js-extension.js
-rw-r--r-- root/root      1239 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-multiple-define.js
-rw-r--r-- root/root      1159 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-named-define.js
-rw-r--r-- root/root      1196 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-object-define.js
-rw-r--r-- root/root      1836 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-require-tourl.js
-rw-r--r-- root/root      5284 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/no-restricted-amd-modules.js
-rw-r--r-- root/root      4637 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/one-dependency-per-line.js
-rw-r--r-- root/root      6186 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/rules/sort-amd-paths.js
drwxr-xr-x root/root         0 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/utils/
-rw-r--r-- root/root      4762 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/utils/ast.js
-rw-r--r-- root/root      9267 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/lib/utils/rjs.js
-rw-r--r-- root/root      1447 2019-03-19 20:42 ./usr/share/nodejs/eslint-plugin-requirejs/package.json

Timestamp: 27.10.2019 / 19:01:17 (UTC)