Debian NEW package overview for node-babel-plugin-lodash
node-babel-plugin-lodash_3.3.4+~cs2.0.1-2_amd64.changes (click to toggle)
Format:1.8
Date:Sat, 09 Jan 2021 07:15:19 +0100
Source:node-babel-plugin-lodash
Binary:node-babel-plugin-lodash
Architecture:source all
Version:3.3.4+~cs2.0.1-2
Distribution:unstable
Urgency:medium
Maintainer:Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Changed-By:Xavier Guimard <yadd@debian.org>
Description:
node-babel-plugin-lodash - Modular Lodash builds without the hassle
Changes:
node-babel-plugin-lodash (3.3.4+~cs2.0.1-2) unstable; urgency=medium

  * Team upload

  [ lintian-brush ]
  * Trim trailing whitespace.
  * Set upstream metadata fields: Bug-Submit.
  * Remove obsolete fields Contact, Name from debian/upstream/metadata
    (already present in machine-readable debian/copyright).

  [ Xavier Guimard ]
  * Bump debhelper compatibility level to 13
  * Add "Rules-Requires-Root: no"
  * Use dh-sequence-nodejs
  * Fix copyright
  * Enable part of upstream test using mocha
Files:
ce5ea715be856a8ae2dbfc8349dcfb06 2870 javascript optional node-babel-plugin-lodash_3.3.4+~cs2.0.1-2.dsc
cbba968951c2423a7556c55cd40ab052 7944 javascript optional node-babel-plugin-lodash_3.3.4+~cs2.0.1-2.debian.tar.xz
b1a68206984d49ec2a2936f752927513 10600 javascript optional node-babel-plugin-lodash_3.3.4+~cs2.0.1-2_all.deb
1c0d4a1b1986eb30a427d751694672fd 13898 javascript optional node-babel-plugin-lodash_3.3.4+~cs2.0.1-2_amd64.buildinfo
node-babel-plugin-lodash_3.3.4+~cs2.0.1-2.dsc (click to toggle)
Format:3.0 (quilt)
Source:node-babel-plugin-lodash
Binary:node-babel-plugin-lodash
Architecture:all
Version:3.3.4+~cs2.0.1-2
Maintainer:Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Uploaders:Pirate Praveen <praveen@debian.org>
Homepage:https://github.com/lodash/babel-plugin-lodash#readme
Standards-Version:4.5.1
Vcs-Browser:https://salsa.debian.org/js-team/node-babel-plugin-lodash
Vcs-Git:https://salsa.debian.org/js-team/node-babel-plugin-lodash.git
Testsuite:autopkgtest-pkg-nodejs
Build-Depends:debhelper-compat (=13), chai<!nocheck>, mocha<!nocheck>, nodejs (>=6), dh-sequence-nodejs, node-babel-cli (>=7.0~), node-babel-plugin-add-module-exports, node-babel-helper-module-imports (>=7.0~), node-babel-types (>=7.0~), node-glob (>=7.1.1), node-lodash (>=4.17.10), rollup
Package-List:node-babel-plugin-lodash deb javascript optional arch=all
Files:
f0185a0b7228773432e51bd0d5255ae1 2363 node-babel-plugin-lodash_3.3.4+~cs2.0.1.orig-require-package-name.tar.gz
d30421b709d19016b4c65ccefe8e594e 50453 node-babel-plugin-lodash_3.3.4+~cs2.0.1.orig.tar.gz
cbba968951c2423a7556c55cd40ab052 7944 node-babel-plugin-lodash_3.3.4+~cs2.0.1-2.debian.tar.xz
lintian 2.94.0~bpo10+1 check for node-babel-plugin-lodash_3.3.4+~cs2.0.1-2.dsc (click to toggle)
README.source for node-babel-plugin-lodash_3.3.4+~cs2.0.1-2.dsc (click to toggle)
No README.source in this package
control file for node-babel-plugin-lodash_3.3.4+~cs2.0.1-2_all.deb (click to toggle)
Package:node-babel-plugin-lodash
Version:3.3.4+~cs2.0.1-2
Architecture:all
Maintainer:Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Installed-Size:47
Depends:nodejs (>=6), node-babel-helper-module-imports (>=7.0~), node-babel-types (>=7.0~), node-glob (>=7.1.1), node-lodash (>=4.17.10)
Provides:node-require-package-name (= 2.0.1)
Section:javascript
Priority:optional
Homepage:https://github.com/lodash/babel-plugin-lodash#readme
Description:
Modular Lodash builds without the hassle
 A simple transform to cherry-pick Lodash modules so one don’t have to.
 This is a plugin for babel transpiler to make using modular lodash easy.
 .
 Babel is a JavaScript compiler to use next generation JavaScript, today.
 .
 Node.js is an event-based server-side JavaScript engine.
lintian 2.94.0~bpo10+1 check for node-babel-plugin-lodash_3.3.4+~cs2.0.1-2_all.deb (click to toggle)
contents of node-babel-plugin-lodash_3.3.4+~cs2.0.1-2_all.deb (click to toggle)
drwxr-xr-x root/root         0 2021-01-09 06:15 ./
drwxr-xr-x root/root         0 2021-01-09 06:15 ./usr/
drwxr-xr-x root/root         0 2021-01-09 06:15 ./usr/share/
drwxr-xr-x root/root         0 2021-01-09 06:15 ./usr/share/doc/
drwxr-xr-x root/root         0 2021-01-09 06:15 ./usr/share/doc/node-babel-plugin-lodash/
-rw-r--r-- root/root      2502 2018-06-11 03:18 ./usr/share/doc/node-babel-plugin-lodash/README.md
-rw-r--r-- root/root       467 2021-01-09 06:15 ./usr/share/doc/node-babel-plugin-lodash/changelog.Debian.gz
-rw-r--r-- root/root      3448 2021-01-09 06:09 ./usr/share/doc/node-babel-plugin-lodash/copyright
drwxr-xr-x root/root         0 2021-01-09 06:15 ./usr/share/nodejs/
drwxr-xr-x root/root         0 2021-01-09 06:15 ./usr/share/nodejs/babel-plugin-lodash/
drwxr-xr-x root/root         0 2021-01-09 06:15 ./usr/share/nodejs/babel-plugin-lodash/lib/
-rw-r--r-- root/root       251 2021-01-09 06:15 ./usr/share/nodejs/babel-plugin-lodash/lib/Map.js
-rw-r--r-- root/root      1228 2021-01-09 06:15 ./usr/share/nodejs/babel-plugin-lodash/lib/MapCache.js
-rw-r--r-- root/root      3605 2021-01-09 06:15 ./usr/share/nodejs/babel-plugin-lodash/lib/ModuleCache.js
-rw-r--r-- root/root       903 2021-01-09 06:15 ./usr/share/nodejs/babel-plugin-lodash/lib/Package.js
-rw-r--r-- root/root      1464 2021-01-09 06:15 ./usr/share/nodejs/babel-plugin-lodash/lib/Store.js
-rw-r--r-- root/root      1308 2021-01-09 06:15 ./usr/share/nodejs/babel-plugin-lodash/lib/config.js
-rw-r--r-- root/root      1418 2021-01-09 06:15 ./usr/share/nodejs/babel-plugin-lodash/lib/importModule.js
-rw-r--r-- root/root      8782 2021-01-09 06:15 ./usr/share/nodejs/babel-plugin-lodash/lib/index.js
-rw-r--r-- root/root       330 2021-01-09 06:15 ./usr/share/nodejs/babel-plugin-lodash/lib/mapping.js
-rw-r--r-- root/root       664 2021-01-09 06:15 ./usr/share/nodejs/babel-plugin-lodash/lib/util.js
-rw-r--r-- root/root      1871 2018-06-11 03:18 ./usr/share/nodejs/babel-plugin-lodash/package.json
drwxr-xr-x root/root         0 2021-01-09 06:15 ./usr/share/nodejs/require-package-name/
-rw-r--r-- root/root       537 2015-05-07 14:11 ./usr/share/nodejs/require-package-name/index.js
-rw-r--r-- root/root       854 2015-05-07 14:11 ./usr/share/nodejs/require-package-name/package.json

Timestamp: 09.01.2021 / 07:00:55 (UTC)